Monthly Archives: December 2014

CCIE R&S Blueprint | CCIE BLOG

jcissell

About Jeremy Cissell -A results-driven IT professional with experience in Cisco Data Systems, Network Administration, Cabling & Infrastructure, Information Systems Project Management & Support.Network Consultant located in Louisville, Kentucky. You can also find me on Twitter, Google+, or Manta.

Latest posts by jcissell (see all)

CCIE BLOG

This expanded blueprint is from ine.com.  If your studying for CCIE then you know what how daunting a task it is.  The below can be used as a checklist for your studies.

As many of you hopefully already know, the CCIE Routing & Switching certification blueprint is changing from version 4 to version 5 on June 3rd 2014. As this date quickly approaches, and as the last of the v4 lab seats are fully booked, it’s time to start planning your attack on the RSv5 blueprint.

While Cisco’s official blueprint for v5 is now more detailed that it has ever been in the past, it still lacks some details in certain areas, for example “Implement, optimize and troubleshoot filtering with any routing protocol.” Additionally it would be difficult to use Cisco’s blueprint for a study plan as it stands in its current linear format. For example “Layer 3 multicast” is listed before “Fundamental routing concepts”, which from a learning perspective doesn’t make sense, because you must understand unicast routing fully before you learn multicast routing. To help remedy this we’ve re-ordered and expanded Cisco’s blueprint into INE’s RSv5 Expanded Blueprint, which you can find below after the jump.

Our CCIE RSv5 Expanded Blueprint is meant to be used as a checklist that you can use as you go through your preparation. This way when you’re finally ready to attempt the lab exam, you can be assured that you’ve at least heard of all the topics in the scope, regardless of how obscure some of them might be. Additionally note that some topics listed below might appear only on the written exam and not the lab exam, such as MPLS Layer 2 VPNs or RIPng, but are still included in our content and the outline below.

The below outline will continue to be updated, so check back periodically during your preparation to see changes, adds, and removes.  Good luck in your studies!

INE’s CCIE RSv5 Expanded Blueprint

Release Notes

Note: Topics in strikethrough have been removed.
Topics with * are covered in the Written Exam only.

Edit 2014-04-21 – Removed the following topics:

802.1q Tunneling
Flex Links
Router IP Traffic Export (RITE)

Edit 2014-04-21 – Marked the following topics as Written Exam Only:

Performance Routing (PfR) *
IPv6 Tunneling *
RIPng *
IS-IS *
AToM *
L2TPV3 *
VPLS *
GETVPN *
IPv6 Multicast Routing *
Layer 2 QoS *
802.1x *
AAA with TACACS+ and RADIUS *
RSv5 Expanded Blueprint

1. LAN Switching
1.1. VLANs & Trunking
1.1.1. Standard VLANs
1.1.2. Extended VLANs
1.1.3. VLAN Database
1.1.4. Access Ports
1.1.5. 802.1q Trunk Ports
1.1.6. 802.1q Native VLAN
1.1.7. Dynamic Trunking Protocol (DTP)
1.1.8. Trunking Allowed List
1.2. VTP
1.2.1. VTP Version 1, 2, & 3
1.2.2. VTP Authentication
1.2.3. VTP Pruning
1.2.4. VTP Prune Eligible List
1.2.5. VTPv3 & Private VLANs
1.3. EtherChannels
1.3.1. Static Layer 2 EtherChannels
1.3.2. PAgP
1.3.3. LACP
1.3.4. Layer 3 EtherChannel
1.3.5. EtherChannel Load Balancing
1.3.6. EtherChannel Protocol Limiting
1.3.7. EtherChannel Misconfig Guard
1.4. Spanning-Tree Protocol
1.4.1. PVST+
1.4.1.1. STP Root Bridge Election
1.4.1.2. STP Path Selection with Port Cost
1.4.1.3. STP Path Selection with Port Priority
1.4.1.4. STP Convergence Timers
1.4.2. Optional STP Features
1.4.2.1. PortFast
1.4.2.2. UplinkFast
1.4.2.3. BackboneFast
1.4.2.4. BPDU Guard
1.4.2.5. BPDU Filter
1.4.2.6. Root Guard
1.4.3. Rapid-PVST+
1.4.3.1. RSTP Convergence Optimizations
1.4.3.2. Edge Ports
1.4.4. Multiple STP
1.4.4.1. MST Root Bridge Election
1.4.4.2. MST Path Selection with Port Cost
1.4.4.3. MST Path Selection with Port Priority
1.4.4.4. MST and CST/PVST+ Interoperability
1.4.4.5. Multi-Region MST
1.5. 802.1q Tunneling
1.5.1. L2 Protocol Tunneling
1.5.2. Layer 2 MTU
1.5.3. EtherChannel over 802.1q Tunneling
1.6. Miscellaneous
1.6.1. CDP
1.6.2. LLDP
1.6.3. UDLD
1.6.4. CAM Aging Time
1.6.5. SPAN
1.6.6. RSPAN
1.6.7. ERSPAN
1.6.8. Flex Links
1.6.9. Fallback Bridging
1.6.10. Voice VLANs
1.6.11. Smartport Macros
2. Layer 2 WAN Circuits
2.1. HDLC
2.2. PPP
2.3. PPP Authentication
2.4. PPP Multilink
2.5. PPPoE
3. IP Routing
3.1. Protocol Independent IPv4 Routing
3.1.1. IPv4 Addressing
3.1.2. IPv4 ARP
3.1.3. Longest Match Routing
3.1.4. Administrative Distance
3.1.5. Static Routing
3.1.6. Route Recursion
3.1.7. Egress Interface vs. Next Hop Static Routing
3.1.8. Default Routing
3.1.9. CEF
3.1.10. Floating Static Routes
3.1.11. Backup Interface
3.1.12. IP Service Level Agreement
3.1.13. Enhanced Object Tracking
3.1.14. Policy Routing
3.1.15. Policy Routing and IP SLA
3.1.16. Local Policy Routing
3.1.17. GRE Tunnels
3.1.18. IP in IP Tunnels
3.1.19. Tunnels & Recursive Routing Errors
3.1.20. On Demand Routing
3.1.21. VRF Lite
3.1.22. Bidirectional Forwarding Detection
3.1.23. Performance Routing (PfR) *
3.2. Protocol Independent IPv6 Routing
3.2.1. IPv6 Link-Local Addressing
3.2.2. IPv6 Unique Local Addressing
3.2.3. IPv6 Global Aggregatable Addressing
3.2.4. IPv6 EUI-64 Addressing
3.2.5. IPv6 Auto-Configuration / SLAAC
3.2.6. IPv6 Global Prefix
3.2.7. IPv6 Redistribution
3.2.8. IPv6 Filtering
3.2.9. IPv6 NAT-PT
3.2.10. IPv6 MP-BGP
3.2.11. IPv6 Tunneling *
3.2.12. Automatic 6to4 Tunneling*
3.2.13. ISATAP Tunneling *
3.3. Common Dynamic Routing Features
3.3.1. Distance Vector vs. Link State vs. Path Vector routing protocols
3.3.2. Passive Interfaces
3.3.3. Routing Protocol Authentication
3.3.4. Route Filtering
3.3.5. Auto Summarization
3.3.6. Manual Summarization
3.3.7. Route Redistribution
3.3.7.1. Prefix Filtering with Route Tagging
3.3.7.2. Prefix Filtering with Manual Lists
3.3.7.3. Prefix Filtering with Administrative Distance
3.3.7.4. Administrative Distance Based Loops
3.3.7.5. Metric Based Loops
3.4. RIP
3.4.1. RIPv2
3.4.1.1. Initialization
3.4.1.1.1. Enabling RIPv2
3.4.1.1.2. RIP Send and Receive Versions
3.4.1.1.3. Split Horizon
3.4.1.1.4. RIPv2 Unicast Updates
3.4.1.1.5. RIPv2 Broadcast Updates
3.4.1.1.6. RIPv2 Source Validation
3.4.1.2. Path Selection
3.4.1.2.1. Offset List
3.4.1.3. Summarization
3.4.1.3.1. Auto-Summary
3.4.1.3.2. Manual Summarization
3.4.1.4. Authentication
3.4.1.4.1. Clear Text
3.4.1.4.2. MD5
3.4.1.5. Convergence Optimization & Scalability
3.4.1.5.1. RIPv2 Convergence Timers
3.4.1.5.2. RIPv2 Triggered Updates
3.4.1.6. Filtering
3.4.1.6.1. Filtering with Passive Interface
3.4.1.6.2. Filtering with Prefix-Lists
3.4.1.6.3. Filtering with Standard Access-Lists
3.4.1.6.4. Filtering with Extended Access-Lists
3.4.1.6.5. Filtering with Offset Lists
3.4.1.6.6. Filtering with Administrative Distance
3.4.1.6.7. Filtering with Per Neighbor AD
3.4.1.7. Default Routing
3.4.1.7.1. RIPv2 Default Routing
3.4.1.7.2. RIPv2 Conditional Default Routing
3.4.1.7.3. RIPv2 Reliable Conditional Default Routing
3.4.2. RIPng *
3.4.2.1. RIPng Overview *
3.5. EIGRP
3.5.1. Initialization
3.5.1.1. Network Statement
3.5.1.2. Multicast vs. Unicast Updates
3.5.1.3. EIGRP Named Mode
3.5.1.4. EIGRP Multi AF Mode
3.5.1.5. EIGRP Split Horizon
3.5.1.6. EIGRP Next-Hop Processing
3.5.2. Path Selection
3.5.2.1. Feasibility Condition
3.5.2.2. Modifying EIGRP Vector Attributes
3.5.2.3. Classic Metric
3.5.2.4. Wide Metric
3.5.2.5. Metric Weights
3.5.2.6. Equal Cost Load Balancing
3.5.2.7. Unequal Cost Load Balancing
3.5.2.8. EIGRP Add-Path
3.5.3. Summarization
3.5.3.1. Auto-Summary
3.5.3.2. Manual Summarization
3.5.3.3. Summarization with Default Routing
3.5.3.4. Summarization with Leak Map
3.5.3.5. Summary Metric
3.5.4. Authentication
3.5.4.1. MD5
3.5.4.2. HMAC SHA2-256bit
3.5.4.3. Automatic key rollover
3.5.5. Convergence Optimization & Scalability
3.5.5.1. EIGRP Convergence Timers
3.5.5.2. EIGRP Query Scoping with Summarization
3.5.5.3. EIGRP Query Scoping with Stub Routing
3.5.5.4. Stub Routing with Leak Map
3.5.5.5. Bandwidth Pacing
3.5.5.6. IP FRR
3.5.5.7. Graceful Restart & NSF
3.5.6. Filtering
3.5.6.1. Filtering with Passive Interface
3.5.6.2. Filtering with Prefix-Lists
3.5.6.3. Filtering with Standard Access-Lists
3.5.6.4. Filtering with Extended Access-Lists
3.5.6.5. Filtering with Offset Lists
3.5.6.6. Filtering with Administrative Distance
3.5.6.7. Filtering with Per Neighbor AD
3.5.6.8. Filtering with Route Maps
3.5.6.9. Per Neighbor Prefix Limit
3.5.6.10. Redistribution Prefix Limit
3.5.7. Miscellaneous EIGRP
3.5.7.1. EIGRP Default Network
3.5.7.2. EIGRP Default Metric
3.5.7.3. EIGRP Neighbor Logging
3.5.7.4. EIGRP Router-ID
3.5.7.5. EIGRP Maximum Hops
3.5.7.6. no next-hop-self no-ecmp-mode
3.5.7.7. EIGRP Route Tag Enhancements
3.5.8. EIGRPv6
3.5.8.1. Enabling EIGRPv6
3.5.8.2. EIGRPv6 Split Horizon
3.5.8.3. EIGRPv6 Next-Hop Processing
3.5.8.4. EIGRPv6 Authentication
3.5.8.5. EIGRPv6 Metric Manipulation
3.5.8.6. EIGRPv6 Default Routing
3.5.8.7. EIGRPv6 Summarization
3.5.8.8. EIGRPv6 Prefix Filtering
3.5.8.9. EIGRPv6 Stub Routing
3.5.8.10. EIGRPv6 Link Bandwidth
3.5.8.11. EIGRPv6 Timers
3.5.8.12. EIGRP IPv6 VRF Lite
3.5.8.13. EIGRP Over The Top
3.6. OSPF
3.6.1. Initialization
3.6.1.1. Network Statement
3.6.1.2. Interface Statement
3.6.2. Network Types
3.6.2.1. Broadcast
3.6.2.2. Non-Broadcast
3.6.2.3. OSPF DR/BDR Election Manipulation
3.6.2.4. Point-to-Point
3.6.2.5. Point-to-Multipoint
3.6.2.6. Point-to-Multipoint Non-Broadcast
3.6.2.7. Loopback
3.6.2.8. LSA Types
3.6.2.9. OSPF Next-Hop Processing
3.6.2.10. Unicast vs. Multicast Hellos
3.6.3. Path Selection
3.6.3.1. Auto-Cost
3.6.3.2. Cost
3.6.3.3. Bandwidth
3.6.3.4. Per-Neighbor Cost
3.6.3.5. Non-Backbone Transit Areas
3.6.3.6. Virtual-Links
3.6.4. Authentication
3.6.4.1. Area
3.6.4.2. Interface level
3.6.4.3. Clear Text
3.6.4.4. MD5
3.6.4.5. Null
3.6.4.6. MD5 with Multiple Keys
3.6.4.7. SHA1-196
3.6.4.8. Virtual link
3.6.5. Summarization
3.6.5.1. Internal Summarization
3.6.5.2. External Summarization
3.6.5.3. Path Selection with Summarization
3.6.5.4. Summarization and Discard Routes
3.6.6. Stub Areas
3.6.6.1. Stub Areas
3.6.6.2. Totally Stubby Areas
3.6.6.3. Not-So-Stubby Areas
3.6.6.4. Not-So-Stubby Areas and Default Routing
3.6.6.5. Not-So-Totally-Stubby Areas
3.6.6.6. Stub Areas with Multiple Exit Points
3.6.6.7. NSSA Type-7 to Type-5 Translator Election
3.6.6.8. NSSA Redistribution Filtering
3.6.7. Filtering
3.6.7.1. Filtering with Distribute-Lists
3.6.7.2. Filtering with Administrative Distance
3.6.7.3. Filtering with Route-Maps
3.6.7.4. Filtering with Summarization
3.6.7.5. LSA Type-3 Filtering
3.6.7.6. Forwarding Address Suppression
3.6.7.7. NSSA ABR External Prefix Filtering
3.6.7.8. Database Filtering
3.6.8. Default Routing
3.6.8.1. Default Routing
3.6.8.2. Conditional Default Routing
3.6.8.3. Reliable Conditional Default Routing
3.6.8.4. Default Cost
3.6.9. Convergence Optimization & Scalability
3.6.9.1. Interface Timers
3.6.9.2. Fast Hellos
3.6.9.3. LSA & SPF Throttling
3.6.9.4. LSA & SPF Pacing
3.6.9.5. Single Hop LFA / IP FRR
3.6.9.6. Multihop LFA
3.6.9.7. Stub Router Advertisement
3.6.9.8. Demand Circuit
3.6.9.9. Flooding Reduction
3.6.9.10. Transit Prefix Filtering
3.6.9.11. Resource Limiting
3.6.9.12. Graceful Restart & NSF
3.6.9.13. Incremental SPF
3.6.10. Miscellaneous OSPF Features
3.6.11. OSPFv3
3.6.11.1. LSA Types
3.6.11.2. OSPFv3
3.6.11.3. OSPFv3 Network Types
3.6.11.4. OSPFv3 Prefix Suppression
3.6.11.5. OSPFv3 Virtual Links
3.6.11.6. OSPFv3 Summarization
3.6.11.7. OSPFv3 IPsec Authentication
3.6.11.8. OSPFv3 Multi AF Mode
3.6.11.9. TTL Security
3.7. BGP
3.7.1. Establishing Peerings
3.7.1.1. iBGP Peerings
3.7.1.2. EBGP Peerings
3.7.1.3. Update Source Modification
3.7.1.4. Multihop EBGP Peerings
3.7.1.5. Neighbor Disable-Connected-Check
3.7.1.6. Authentication
3.7.1.7. TTL Security
3.7.1.8. BGP Peer Groups
3.7.1.9. 4 Byte ASNs
3.7.1.10. Active vs. Passive Peers
3.7.1.11. Path MTU Discovery
3.7.1.12. Multi Session TCP Transport per AF
3.7.1.13. Dynamic BGP Peering
3.7.2. iBGP Scaling
3.7.2.1. Route Reflectors
3.7.2.2. Route Reflector Clusters
3.7.2.3. Confederations
3.7.3. BGP Next Hop Processing
3.7.3.1. Next-Hop-Self
3.7.3.2. Manual Next-Hop Modification
3.7.3.3. Third Party Next Hop
3.7.3.4. Next Hop Tracking
3.7.3.5. Conditional Next Hop Tracking
3.7.3.6. BGP Next-Hop Trigger Delay
3.7.4. BGP NLRI Origination
3.7.4.1. Network Statement
3.7.4.2. Redistribution
3.7.4.3. BGP Redistribute Internal
3.7.4.4. Conditional Advertisement
3.7.4.5. Conditional Route Injection
3.7.5. BGP Bestpath Selection
3.7.5.1. Weight
3.7.5.2. Local Preference
3.7.5.3. AS-Path Prepending
3.7.5.4. Origin
3.7.5.5. MED
3.7.5.6. Always Compare MED
3.7.5.7. Deterministic MED
3.7.5.8. AS-Path Ignore
3.7.5.9. Router-IDs
3.7.5.10. DMZ Link Bandwidth
3.7.5.11. Maximum AS Limit
3.7.5.12. Multipath
3.7.6. BGP Aggregation
3.7.6.1. BGP Auto-Summary
3.7.6.2. Aggregation
3.7.6.3. Summary Only
3.7.6.4. Suppress Map
3.7.6.5. Unsuppress Map
3.7.6.6. AS-Set
3.7.6.7. Attribute-Map
3.7.6.8. Advertise Map
3.7.7. BGP Communities
3.7.7.1. Standard
3.7.7.2. Extended
3.7.7.3. No-Advertise
3.7.7.4. No-Export
3.7.7.5. Local-AS
3.7.7.6. Deleting
3.7.8. Filtering
3.7.8.1. Prefix-Lists
3.7.8.2. Standard Access-Lists Task
3.7.8.3. Extended Access-Lists
3.7.8.4. Maximum Prefix
3.7.8.5. BGP Regular Expressions
3.7.8.6. Outbound Route Filtering (ORF)
3.7.8.7. Soft Reconfiguration Inbound
3.7.9. AS-Path Manipulation
3.7.9.1. Local AS
3.7.9.2. Local AS Replace-AS/Dual-AS
3.7.9.3. Remove Private AS
3.7.9.4. Allow AS In
3.7.9.5. AS Override
3.7.10. BGP Convergence Optimization
3.7.10.1. BGP Timers Tuning
3.7.10.2. BGP Fast Fallover
3.7.10.3. BGP Prefix Independent Convergence (PIC)
3.7.10.4. BGP Dampening
3.7.10.5. BGP Dampening with Route-Map
3.7.10.6. BGP Add Path
3.7.11. BGP Default Routing
3.7.12. IPv6 BGP
3.7.13. Misc BGP
3.7.13.1. iBGP Synchronization
3.7.13.2. BGP over GRE
3.7.13.3. BGP Backdoor
3.8. Route Redistribution
3.8.1. Metric Based Loops
3.8.2. Administrative Distance Based Loops
3.8.3. Route Tag Filtering
3.8.4. IP Route Profile
3.8.5. Debug IP Routing
3.9. Miscellaneous Routing Features
3.10. IS-IS *
4. VPN
4.1. MPLS
4.1.1. VRF Lite
4.1.2. MPLS LDP
4.1.3. MPLS Ping
4.1.4. MPLS Traceroute
4.1.5. MPLS Label Filtering
4.1.6. MP-BGP VPNv4
4.1.7. MP-BGP Prefix Filtering
4.1.8. PE-CE Routing with RIP
4.1.9. PE-CE Routing with OSPF
4.1.10. OSPF Sham-Link
4.1.11. PE-CE Routing with EIGRP
4.1.12. EIGRP Site-of-Origin
4.1.13. PE-CE Routing with BGP
4.1.14. BGP SoO Attribute
4.1.15. Internet Access
4.1.16. Route Leaking
4.1.17. MPLS VPN Performance Tuning
4.1.18. AToM *
4.1.19. L2TPV3 *
4.1.20. VPLS *
4.2. IPsec LAN-to-LAN
4.2.1. ISAKMP Policies
4.2.2. PSK Authentication
4.2.3. Static Crypto Maps
4.2.4. IPsec over GRE
4.2.5. Static VTI
4.2.6. GETVPN *
4.3. DMVPN
4.3.1. Single Hub
4.3.2. NHRP
4.3.3. DMVPN Phase 1, 2, & 3
4.3.4. QoS Profiles
4.3.5. QoS Pre-Classify
5. Multicast
5.1. Layer 2 Multicast
5.1.1. IGMPv1, IGMPv2, IGMPv3
5.1.2. IGMP Snooping
5.1.3. IGMP Querier Election
5.1.4. IGMP Filtering
5.1.5. IGMP Proxy
5.1.6. IGMP Timers
5.1.7. Multicast VLAN Registration
5.1.8. IGMP Profiles
5.2. IPv4 Multicast Routing
5.2.1. PIM Dense Mode
5.2.2. PIM Sparse Mode
5.2.3. PIM Sparse Dense Mode
5.2.4. Static RP
5.2.5. Auto-RP
5.2.5.1. Auto-RP
5.2.5.2. Sparse Dense Mode
5.2.5.3. Auto-RP Listener
5.2.5.4. Multiple Candidate RPs
5.2.5.5. Filtering Candidate RPs
5.2.5.6. RP & MA placement problems
5.2.6. Bootstrap Router
5.2.6.1. BSR
5.2.6.2. Multiple RP Candidates
5.2.6.3. Multiple BSR Candidates
5.2.7. Source Specific Multicast
5.2.8. Bidirectional PIM
5.2.9. Group to RP Mapping
5.2.10. Anycast RP
5.2.11. MSDP
5.2.12. MSDP SA Filtering
5.2.13. Multicast TTL Scoping
5.2.14. Auto-RP & BSR Boundary Filtering
5.2.15. PIM Accept Register Filtering
5.2.16. PIM Accept RP Filtering
5.2.17. RPF Failure
5.2.18. Registration Failure
5.2.19. PIM DR Election
5.2.20. PIM DF Election
5.2.21. PIM Assert
5.2.22. Static Multicast Routes
5.2.23. Multicast BGP
5.2.24. PIM NBMA Mode
5.2.25. Multicast over GRE
5.2.26. Stub Multicast Routing
5.2.27. Multicast Helper Map
5.2.28. Multicast Rate Limiting
5.2.29. Multicast BGP
5.3. IPv6 Multicast Routing *
5.3.1. IPv6 PIM and MLD *
5.3.2. IPv6 PIM BSR *
5.3.3. IPv6 Embedded RP *
5.3.4. IPv6 SSM *
6. QoS
6.1. Hold-Queue and Tx-Ring
6.2. Weighted Fair Queuing (WFQ)
6.3. Selective Packet Discard
6.4. Payload Compression on Serial Links
6.5. Generic TCP/UDP Header Compression
6.6. MLP Link Fragmentation and Interleaving
6.7. MQC Classification and Marking
6.8. MQC Bandwidth Reservations and CBWFQ
6.9. MQC Bandwidth Percent
6.10. MQC LLQ and Remaining Bandwidth Reservations
6.11. MQC WRED
6.12. MQC Dynamic Flows and WRED
6.13. MQC WRED with ECN
6.14. MQC Class-Based Generic Traffic Shaping
6.15. MQC Class-Based GTS and CBWFQ
6.16. MQC Single-Rate Three-Color Policer
6.17. MQC Hierarchical Policers
6.18. MQC Two-Rate Three-Color Policer
6.19. MQC Peak Shaping
6.20. MQC Percent-Based Policing
6.21. MQC Header Compression
6.22. Voice Adaptive Traffic Shaping
6.23. Voice Adaptive Fragmentation
6.24. Advanced HTTP Classification with NBAR
6.22. Layer 2 QoS *
7. Security
7.1. Layer 2 Security
7.1.1. Port Protection
7.1.2. Private VLANs
7.1.3. Port Based ACLs
7.1.4. VLAN ACLs for IP Traffic
7.1.5. VLAN ACLs for Non-IP Traffic
7.1.6. Storm Control
7.1.7. Port Security
7.1.8. HSRP and Port-Security
7.1.9. ErrDisable Recovery
7.1.10. DHCP Snooping
7.1.11. DHCP Snooping and the Information Option
7.1.12. Dynamic ARP Inspection
7.1.13. IP Source Guard
7.1.14. 802.1x *
7.2. Management Plane Security
7.2.1. AAA Authentication Lists
7.2.2. AAA Exec Authorization
7.2.3. AAA Local Command Authorization
7.2.4. Controlling Terminal Line Access
7.2.5. IOS Login Enhancements
7.2.6. IOS Resilient Configuration
7.2.7. Role-Based CLI
7.2.8. AAA with TACACS+ and RADIUS *
7.3. Control Plane Security
7.3.1. Controlling the ICMP Messages Rate
7.3.2. Control Plane Policing
7.3.3. Control Plane Protection (CPPr)
7.3.4. Control Plane Host
7.4. Data Plane Security
7.4.1. Traffic Filtering Using Standard Access-Lists
7.4.2. Traffic Filtering Using Extended Access-Lists
7.4.3. Traffic Filtering Using Reflexive Access-Lists
7.4.4. IPv6 Traffic Filter
7.4.5. Filtering Fragmented Packets
7.4.6. Filtering Packets with Dynamic Access-Lists
7.4.7. Filtering Traffic with Time-Based Access Lists
7.4.8. Traffic Filtering with Policy-Based Routing
7.4.9. Preventing Packet Spoofing with uRPF
7.4.10. Using NBAR for Content-Based Filtering
7.4.11. TCP Intercept
7.4.12. TCP Intercept Watch Mode
7.4.13. Packet Logging with Access-Lists
7.4.14. IP Source Tracker
7.4.15. Router IP Traffic Export (RITE)
7.4.16. IOS ACL Selective IP Option Drop
7.4.17. Flexible Packet Matching
7.4.18. IPv6 First Hop Security
7.4.18.1. RA guard
7.4.18.2. DHCP guard
7.4.18.3. Binding table
7.4.18.4. Device tracking
7.4.18.5. ND inspection/snooping
7.4.18.6. Source guard
7.4.18.7. PACL
8. System Management
8.1. Device Management
8.1.1. Console
8.1.2. Telnet
8.1.2.1. Telnet Service Options
8.1.3. SSH
8.1.4. Terminal Line Settings
8.1.5. HTTP Server and Client
8.1.6. FTP Server and Client
8.1.7. TFTP Server and Client
8.1.8. SNMP
8.1.8.1. SNMPv2 Server
8.1.8.2. SNMPv2c Access Control
8.1.8.3. SNMP Traps and Informs
8.1.8.4. CPU and Memory Thresholds
8.1.8.5. SNMPv3
8.1.8.6. SNMP MAC Address Notifications
8.1.8.7. SNMP Notifications of Syslog Messages
8.2. Logging
8.2.1. System Message Logging
8.2.2. Syslog Logging
8.2.3. Logging Counting and Timestamps
8.2.4. Logging to Flash Memory
8.2.5. Configuration Change Notification and Logging
8.2.6. Configuration Archive and Rollback
8.2.7. Logging with Access-Lists
8.3. NTP
8.3.1. NTP
8.3.2. NTP Authentication
8.3.3. NTP Access Control
8.3.4. NTP Version 3 & 4
8.4. EEM
8.4.1. KRON Command Schedule
8.4.2. EEM Scripting: Interface Events
8.4.3. EEM Scripting: Syslog Events
8.4.4. EEM Scripting: CLI Events
8.4.5. EEM Scripting: Periodic Scheduling
8.4.6. EEM Scripting: Advanced Features
8.4.7. EEM Applets
8.5. Miscellaneous System Management
8.5.1. Auto-Install over LAN Interfaces using DHCP
8.5.2. Auto-Install over LAN Interfaces Using RARP
8.5.3. IOS Menus
8.5.4. IOS Banners
8.5.5. Exec Aliases
8.5.6. TCP Keepalives
8.5.7. Generating Exception Core Dumps
8.5.8. Conditional Debugging
8.5.9. Tuning Packet Buffers
8.5.10. CDP
8.5.11. Remote Shell
9. Network Services
9.1. Object Tracking
9.1.1. IP SLA
9.1.2. Enhanced Object Tracking
9.1.3. Tracking Lists
9.2. First Hop Redundancy Protocols
9.2.1. HSRP
9.2.2. VRRP
9.2.3. GLBP
9.2.4. Router Redundancy and Object Tracking
9.2.5. IPv6 RS & RA Redundancy
9.3. DHCP
9.3.1. DHCP Server
9.3.2. DHCP Client
9.3.3. DHCP Relay
9.3.4. DHCP Host Pools
9.3.5. DHCP On-Demand Pool
9.3.6. DHCP Proxy
9.3.7. DHCP Information Option
9.3.8. DHCP Authorized ARP
9.3.9. SLAAC/DHCPv6 interaction
9.3.10. Stateful & Stateless DHCPv6
9.3.11. DHCPv6 prefix delegation
9.4. DNS
9.4.1. IOS Authoritative DNS Server
9.4.2. IOS Caching DNS Server
9.4.3. IOS DNS Spoofing
9.5. NAT
9.5.1. Basic NAT
9.5.2. NAT Overload
9.5.3. NAT with Route Maps
9.5.4. Static NAT
9.5.5. Static PAT
9.5.6. Static NAT and IP Aliasing
9.5.7. Static Policy NAT
9.5.8. NAT with Overlapping Subnets
9.5.9. TCP Load Distribution with NAT
9.5.10. Stateful NAT with HSRP
9.5.11. Stateful NAT with Primary/Backup
9.5.12. NAT Virtual Interface
9.5.13. NAT Default Interface
9.5.14. Reversible NAT
9.5.15. Static Extendable NAT
9.5.16. NAT ALG
9.6. Traffic Accounting
9.6.1. IP Precedence Accounting
9.6.2. IP Output Packet Accounting
9.6.3. IP Access Violation Accounting
9.6.4. MAC Address Accounting
9.7. NetFlow
9.7.1. Netflow v5 & v9
9.7.2. Netflow Ingress and Egress
9.7.3. Netflow Top Talkers
9.7.4. Netflow Aggregation Cache
9.7.5. Netflow Random Sampling
9.7.6. Netflow Input Filters
9.7.7. Netflow Export
9.8. Miscellaneous Network Services
9.8.1. Proxy ARP
9.8.2. IRDP
9.8.3. Router ICMP Settings
9.8.3.1. TCP Optimization
9.8.4. IOS Small Services and Finger
9.8.5. Directed Broadcasts and UDP Forwarding
9.8.6. NBAR Protocol Discovery
9.8.7. IP Event Dampening
9.8.8. Conditional Debugging
9.8.9. Embedded Packet Capture
9.8.10. Interpreting Packet Captures
Tags: blueprint, expanded, rsv5

Sample CCNP BGP config | Kentucky

jcissell

About Jeremy Cissell -A results-driven IT professional with experience in Cisco Data Systems, Network Administration, Cabling & Infrastructure, Information Systems Project Management & Support.Network Consultant located in Louisville, Kentucky. You can also find me on Twitter, Google+, or Manta.

Latest posts by jcissell (see all)

Louisville Cisco Setups

See below a sample cisco router bgp config.  This a a config i used in a study lab from my ccnp route exam. 

int loop 0
ip add 1.1.1.1 255.255.255.255
int s1/0
ip add 12.12.12.1 255.255.255.0
no shut

ip route 2.2.2.2 255.255.255.255 12.12.12.2

router bgp 12
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source loop 0
network 1.1.1.1 mask 255.255.255.255

R2

int loop 0
ip add 2.2.2.2 255.255.255.255
int s1/0
ip add 12.12.12.2 255.255.255.0
no shut
int s1/1
ip add 23.23.23.2 255.255.255.0
no shut

ip route 1.1.1.1 255.255.255.255 12.12.12.1
ip route 3.3.3.3 255.255.255.255 23.23.23.3

router bgp 12
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source loop 0
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 update-source loop 0
neighbor 3.3.3.3 e

R3

int loop 0
ip add 3.3.3.3 255.255.255.255
int s1/1
ip add 34.34.34.3 255.255.255.0
no shut
int s1/0
ip add 23.23.23.3 255.255.255.0
no shut

ip route 4.4.4.4 255.255.255.255 34.34.34.4
ip route 2.2.2.2 255.255.255.255 23.23.23.2

router bgp 34
neighbor 4.4.4.4 remote-as 34
neighbor 4.4.4.4 update-source loop 0
neighbor 4.4.4.4 next-hop-self
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source loop 0
neighbor 2.2.2.2 e

R4

int loop 0
ip add 4.4.4.4 255.255.255.255
int s1/0
ip add 34.34.34.4 255.255.255.0
no shut

ip route 3.3.3.3 255.255.255.255 34.34.34.3

router bgp 34
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 update-source loop 0
network 4.4.4.4 mask 255.255.255.255

Louisville Google Ranking

jcissell

About Jeremy Cissell -A results-driven IT professional with experience in Cisco Data Systems, Network Administration, Cabling & Infrastructure, Information Systems Project Management & Support.Network Consultant located in Louisville, Kentucky. You can also find me on Twitter, Google+, or Manta.

Latest posts by jcissell (see all)

Website Rankings Louisville Kentucky

If you’re like most SEOs, you spend a lot of time reading. Over the past several years, I’ve spent 100s of hours studying blogs, guides, and Google patents. Not long ago, I realized that 90% of what I read each doesn’t change what I actually do – that is, the basic work of ranking a web page higher on Google.

Call today for free eval 270-401-7950

For newer SEOs, the process can be overwhelming.

To simplify this process, I created this SEO blueprint. It’s meant as a framework for newer SEOs to build their own work on top of. This basic blueprint has helped, in one form or another, 100s of pages and dozens of sites to gain higher rankings.

Think of it as an intermediate SEO instruction manual, for beginners.

Level: Beginner to Intermediate

Timeframe: 2 to 10 Weeks

What you need to know: The blueprint assumes you have basic SEO knowledge: you’re not scared of title tags, can implement a rel=canonical, and you’ve built a link or two. (If this is your first time to the rodeo, we suggest reading the Beginners Guide to SEO and browsing our Learn SEO section.)

How To Rank SEO Blueprint

Table of Contents

Keyword Research

1. Working Smarter, Not Harder

Keyword research can be simple or hard, but it should always be fun. For the sake of the Blueprint, let’s do keyword research the easy way.

The biggest mistakes people make with keyword research are:

Choosing keywords that are too broad
Keywords with too much competition
Keywords without enough traffic
Keywords that don’t convert
Trying to rank for one keyword at a time
The biggest mistake people make is trying to rank for a single keyword at a time. This is the hard way. It’s much easier, and much more profitable, to rank for 100s or even 1,000s of long tail keywords with the same piece of content.

Instead of ranking for a single keyword, let’s aim our project around a keyword theme.

2. Dream Your Keyword Theme

Using keyword themes solves a whole lot of problems. Instead of ranking for one Holy Grail keyword, a better goal is to rank for lots of keywords focused around a single idea. Done right, the results are amazing.

Easy Keyword Research

I assume you know enough about your business to understand what type of visitor you’re seeking and whether you’re looking for traffic, conversions, or both. Regardless, one simple rule holds true: the more specific you define your theme, the easier it is to rank.

This is basic stuff, but it bears repeating. If your topic is the football, you’ll find it hard to rank for “Super Bowl,” but slightly easier to rank for “Super Bowl 2014” – and easier yet to rank for “Best Super Bowl Recipes of 2014.”

Don’t focus on specific words yet – all you need to know is your broad topic. The next step is to find the right keyword qualifiers.

3. Get Specific with Qualifiers

Qualifiers are words that add specificity to keywords and define intent. They take many different forms.

Time/Date: 2001, December, Morning
Price/Quality: Cheap, Best, Most Popular
Intent: Buy, Shop, Find
Location: Houston, Outdoors, Online
The idea is to find as many qualifiers as possible that fit your audience. Here’s where keyword tools enter the picture. You can use any keyword tool you like, but favorites include Wordstream, Keyword Spy, SpyFu, and Bing Keyword Tool and Übersuggest.

For speed and real-world insight, Übersuggest is an all-time SEO favorite. Run a simple query and export over 100 suggested keyword based on Google’s own Autocomplete feature – based on actual Google searches.

Did I mention it’s free?

4. Finding Diamonds in the Google Rough

At this point you have a few dozen, or a few hundred keywords to pull into Google Adwords Keyword Planner.

Pro Tip #1: While it’s possible to run over a hundred keyword phrases at once in Google’s Keyword Planner, you get more variety if you limit your searches to 5-10 at a time.

Ubersuggest and Google Keyword Tool

Using “Exact” search types, we’re looking for 10-15 closely related keyword phrases with decent search volume, but not too much competition.

Pro Tip #2: Be careful trusting the “Competition” column in Google Adwords Keyword Planner. This refers to bids on paid search terms, not organic search.

5. Get Strategic with the Competition

Now that we have a basic keyword set, you need to find out if you can actually rank for your phrases. You have two basic methods of ranking the competition:

Automated tools like the Keyword Difficulty Tool
Eyeballing the SERPs
If you have an SEOmoz PRO membership (or even a free trial) the Keyword Difficulty Tool calculates – on a 100 point scale – a difficulty score for each individual keyword phrase you enter.

Keyword Difficulty Tool

Keyword phrases in the 60-70+ range are typically competitive, while keywords in the 30-40 range might be considered low to moderately difficult.

To get a better idea of your own strengths, take the most competitive keyword you currently rank #1 or #2 for, and run it through the tool.

Even without automated tools, the best way to size up the competition is to eyeball the SERPs. Run a search query (non-personalized) for your keywords and ask yourself the following questions:

Are the first few results optimized for the keyword?
Is the keyword in the title tag? In the URL? On the page?
What’s the Page and/or Domain Authority of the URL?
Are the first few results authorities on the keyword subject?
What’s the inbound anchor text?
Can you deliver a higher quality resource for this keyword?
You don’t actually have to rank #1 for any of your chosen words to earn traffic, but you should be comfortable cracking the top five.

With keyword themes, the magic often happens from keywords you never even thought about.

Case Study: Google Algo Update

When SEOmoz launched the Google Algorithm Change HIstory (run by Dr. Pete) we used a similar process for keyword research to explore the theme “Google Algorithm” and more specifically, “Google Algorithm Change.”

According to Google’s search tool, we could expect a no more than a couple thousand visits a month – best case – for these exact terms. Fortunately, because the project was well received and because we optimized around a broad keyword theme of “Google Algorithm,” the Algo Update receives lots of traffic outside our pre-defined keywords.

This is where the long tail magic happens:

Long Tail Keywords
How can you improve your chances of ranking for more long tail keywords? Let’s talk about content, architecture, on-page optimization and link building.

Content

6. Creating Value

Want to know the truth? I hate the word content. It implies words on a page, a commodity to be produced, separated from the value it creates.

Content without value is spam.

In the Google Algorithm Update example above, we could have simply written 100 articles about Google’s Algorithm and hoped to rank. Instead, the conversation started by asking how we could create a valuable resource for webmasters.

For your keyword theme, ask first how you can create value.

Value is harder to produce than mere words, but value is rewarded 100x more. Value is future proof & algorithm proof. Value builds links by itself. Value creates loyal fans.

Value takes different forms. It’s a mix of:

Utility
Emotional response
Point of view (positive or negative)
Perceived value, including fame of the author
Your content doesn’t have to include all 4 of these characteristics, but it should excel in one or more to be successful.

A study of the New York Times found key characteristics of content to be influential in making the Most Emailed list.

New York Times Most Emailed
Source: http://papers.ssrn.com/sol3/papers.cfm?abstract_id=1528077\

7. Driving Your Content Vehicle

Here’s a preview: the Blueprint requires you create at least one type of link bait, so now is a good time to think about the structure of your content.

What’s the best way to deliver value given your theme? Perhaps it’s an

Infographic
Video series
A new tool
An interview series
Slide deck
How-to guide
Q&A
Webinar or simple blog post
Perhaps, it’s all of these combined.

The more ways you find to deliver your content and the more channels you take advantage of, the better off you’ll be.

Not all of your content has to go viral, but you want to create at least one “tent-pole” piece that’s better than anything else out there and you’re proud to hang your hat on.

If you need inspiration, check out Distilled’s guide to Viral Linkbait or QuickSprout’s Templates for Content Creation.

8. Title – Most Important Work Goes Here

Spend two hours, minimum, writing your title.

Sound ridiculous? If you’re an experienced title writer like Rand Fishkin, you can break this rule. For the rest of us, it’s difficult to underplay the value delivered by a finely crafted title.

Write 50 titles or more before choosing one.

Study the successful titles on Inbound.org, Mashable, Wired, or your favorite publication.

Headline Formulas Work

Whatever you do, read this fantastic post by Dan Shure and the headline resources at CopyBlogger.

9. Length vs. Depth – Why it Matters

How long should your content be? A better question is: How deep should it be? Word count by itself is a terrible metric to strive for, but depth of content helps you to rank in several ways.

Adds uniqueness threshold to avoid duplicate content
Deeper topic exploration makes your content “about” more
Quality, longer content is correlated with more links and higher rankings
I. Uniqueness

At a minimum, your content needs to meet a minimum uniqueness threshold in order for it to rank. Google reps have gone on record to say a couple sentences is sometimes sufficient, but in reality a couple hundred words is much safer.

II. Long Tail Opportunities

Here’s where the real magic happens. The deeper your content and the more in-depth you can explore a particular topic, the more your content becomes “about.”

The more your content is “about”, the more search queries it can answer well.

The more search queries you can answer well, the more traffic you can earn.

Google’s crawlers continuously read your content to determine how relevant it is to search queries. They evaluate paragraphs, subject headings, photographs and more to try to understand your page. Longer, in-depth content usually send more relevancy signals than a couple short sentences.

III. Depth, Length, and Links

Numerous correlation studies have shown a positive relationship between rankings and number of words in a document.

“The length in HTML and the HTML within the tag were the highest correlated factors, in fact with correlations of .12 they could be considered somewhat if not hugely significant.

While these factors probably are not implemented within the algorithm, they are good signs of what Google is looking for; quality content, which in many cases means long or at least sufficiently lengthy pages.”

– Mark Collier The Open Algorithm
This could be attributed longer, quality content earning more links. John Doherty examined the relationship between the length of blog posts on SEOmoz and the number of links each post earned, and found a strong relationship.

Links based on wordcount

10. Content Qualities You Can Bank On

If you don’t focus on word count, how do you add quality “depth” to your content?

SEOs have written volumes about how Google might define quality including metrics such as reading level, grammar, spelling, and even Author Rank. Most is speculation, but it’s clear Google does use guidelines to separate good content from bad.

My favorite source for clues comes from the set of questions Google published shortly after the first Panda update. Here are a few of my favorites.

Google Panda Questions

11. LDA, nTopic, and Words on the Page

Google is a machine. It can’t yet understand your page like a human can, but it’s getting close.

Search engines use sophisticated algorithms to model your sentences, paragraphs, blocks, and content sections. Not only do they want to understand your keywords, but also your topic, intent, and expertise as well.

How do you know if your content fits Google’s model of expectations?

For example, if your topic is “Super Bowl Recipes,” Google might expect to see content about grilling, appetizers, and guacamole. Content that addresses these topics will likely rank higher than pages that talk about what color socks you’re wearing today.

Words matter.

SEOs have discovered that using certain words around a topic associated with concepts like LDA and nTopic are correlated with higher rankings.

Virante offers an interesting stand alone keyword suggestion tool called nTopic. The tools analyzes your keywords and suggests related keywords to improve your relevancy scores.

nTopic

12. Better than LDA – Poor Man’s Topic Modeling

Since we don’t have access to Google’s computers for topic modeling, there’s a far simpler way to structure your content that I find far superior to worrying about individual words:

Use the keyword themes you created at the beginning of this blueprint.

You’ve already done the research using Google’s keyword tool to find closely related keyword groups. Incorporating these topics into your content may help increase your relevancy to your given topic.

Example: Using the Google Algorithm project cited above, we found during keyword research that certain keywords related to our theme show up repeatedly, time and time again. If we conducted this research today, we would find phrases like “Penguin SEO” and “Panda Updates” frequently in our results.

Google suggests these terms via the keyword tool because they consider them closely related. So any content that explored “Google Algorithm Change” might likely include a discussion of these ideas.

Poor Man’s Topic Modeling

Note: This isn’t real LDA, simply a way of adding relevant topics to your content that Google might associate with your subject matter.

13. Design Is 50% of the Battle

If you have any money in your budget, spend it on design. A small investment with a designer typically pays outsized dividends down the road. Good design can:

Lower bounce rate
Increase page views
Increase time on site
Earn more links
Establish trust
… All of which can help earn higher rankings.

“Design doesn’t just matter, it’s 50% of the battle.”
-Rand Fishkin
Dribbble.com

Dribbble.com is one of our favorite source of design inspiration.

Architecture

Here’s the special secret of the SEO Blueprint: you’re not making a single page to rank; you’re making several.

14. Content Hubs

Very few successful websites consist of a single page. Google determines context and relevancy not only by what’s on your page, but also by the pages around it and linking to it.

The truth is, it’s far easier to rank when you create Content Hubs exploring several topics in depth focused around a central theme.

Using our “Super Bowl Recipes” example, we might create a complete section of pages, each exploring a different recipe in depth.

Content Hub for SEO

15. Linking the Hub Together

Because your pages now explore different aspects of the same broad topic, it makes sense to link them together.

Your page about guacamole relates to your page about nachos.
Your page about link building relates to your page about infographics.
Your page about Winston Churchill relates to major figures of World War II.
Linking Your Content Hub

It also helps them to rank by distributing PageRank, anchor text, and other relevancy signals.

16. Find Your Center

Content Hubs work best with a “hub” or center. Think of the center as the master document that acts as an overview or gateway to all of your individual content pages.

The hub is the authority page. Often, the hub is a link bait page or a category level page. It’s typically the page with the most inbound links and often as a landing page for other sections of your site.

Center of the SEO Content Hub

For great example of Hub Pages, check out:

CopyBloggers Magnetic Headlines
Moz’s Learn SEO
Amazon’s author pages (this one about Stephen King)
On-Page Optimization

17. Master the Basics

You could write an entire book about on-page optimization. If you’re new to SEO, one of the best ways to learn is by using Moz’s On-page Report Card. The tool grades 36 separate on-page SEO elements, gives you a report and suggestions on how to fix each element. Working your way through these issues is an excellent way to learn (and often used by agencies and companies as a way to teach SEO principals)

On-Page Tool

Beyond the basics, let’s address a few slightly more advanced tactics to take advantage of your unique keyword themes and hub pages, in addition to areas where beginners often make mistakes.

18. Linking Internally for the Reasonable Surfer

Not all links are created equal (One of the greatest SEO blog posts ever written!) So, when you interlink your internal pages within your content hub together, keep in mind a few important points.

Links from inside unique content pass more value than navigation links.
Links higher up the page pass more value than links further down.
Links in HTML text pass more weight than image links.
When interlinking your content, it’s best to keep links prominent and “editorial” – naturally link to your most important content pages higher up in the HTML text.

19. Diversify Your Anchor Text – Naturally

If Google’s Penguin update taught us anything, it’s that over-thinking anchor text is bound to get us in trouble.

When you link naturally and editorially to other places on the web, you naturally diversify your anchor text. The same should hold true when you link internally.

Don’t choose your anchor text to fit your keywords; choose your anchor text to fit the content around it.

Practically speaking, this means linking internally with a mix of partial match keyword and related phrases. Don’t be scared to link occasionally without good keywords in the anchor – the link can still pass relevancy signals. When it comes to linking, it’s safer to under-do it than over-do it.

Choose Descriptive Anchor Text

Source: Google’s SEO Starter Guide

20. Title Tags – Two Quick Tips

We assume you know how to write a compelling title tag. Even today, keyword usage in the title tag is one of the most highly correlated on-page ranking factors that we know.

That said, Google is getting strict about over-optimizing title tags, and appears to be further cracking down on titles “written for SEO.” Keep this in mind when crafting your title tags

I. Avoid Boilerplates

It used to be common to tack on your business phrase or main keywords to the end of every title tag, like so:

Plumbing Supplies – Chicago Plumbing and Fixtures
Pipes & Fittings – Chicago Plumbing and Fixtures
Toilet Seat Covers – Chicago Plumbing and Fixtures
While we don’t have much solid data, many SEOs are now asserting that “boilerplate” titles tacked on to the end of every tag are no longer a good idea. Brand names and unique descriptive information is okay, but making every title as unique as possible is the rule of the day.

II. Avoid Unnecessary Repetition

Google also appears (at least to many SEOs) to be cracking down on what’s considered the lower threshold of “keyword stuffing.”

In years past it was a common rule of thumb never to repeat your keyword more than twice in the title. Today, to be on the safe side, you might be best to consider not repeating your keywords more than once.

21. Over-Optimization: Titles, URLs, and Links

Writing for humans not only gets you more clicks (which can lead to higher rankings), but hardly ever gets you in trouble with search engines.

As SEOs we’re often tempted to get a “perfect score” which means exactly matching our title tags, URLs, inbound anchor text, and more. unfortunately, this isn’t natural in the real world, and Google recognizes this.

Diversify. Don’t over-optimize.

22. Structured Data

Short and simple: Make structured data part of every webpage. While structured data hasn’t yet proven to be a large ranking factor, it’s future-facing value can be seen today in rich snippet SERPs and social media sharing. In some verticals, it’s an absolute necessity.

rich snippets

There’s no rule of thumb about what structured data to include, but the essentials are:

Facebook Open Graph tags
Twitter Cards
Authorship
Publisher
Business information
Reviews
Events
To be honest, if you’re not creating pages with structured data, you’re probably behind the times.

For an excellent guide about Micro Data and Schema.org, check out this fantastic resource from SEOGadget.

Building Links

23. The 90/10 Rule of Link Building

This blueprint contains 25 steps to rank your content, but only the last three address link building. Why so few? Because 90% of your effort should go into creating great content, and 10% into link building.

If you have a hard time building links, it may be because you have these numbers reversed.

Creating great content first solves a ton of problems down the line:

Good content makes link building easier
Attracts higher quality links in less time
Builds links on its own even when sleeping or on vacation
If you’re new to marketing or relatively unknown, you may need to spend more than 10% of your time building relationships, but don’t let that distract you from crafting the type of content that folks find so valuable they link to you without you even asking.

90-10 Rule of Link Building

24. All Link Building is Relationships – Good & Bad

This blueprint doesn’t go into link building specifics, as there are 100’s of ways to build quality links to every good project. That said, a few of my must have link building resources:

Jon Cooper’s Complete List of Link Building Strategies
StumbleUpon Paid Discovery
Citation Labs
Promoted Tweets
Ontolo
eReleases – Press releases not for links, but for exposer
BuzzStream
Paddy Moogan’s excellent Link Building Book
These resources give you the basic tools and tactics for a successful link building campaign, but keep in mind that all good link building is relationship building.

Successful link builders understand this and foster each relationship and connection. Even a simple outreach letter can be elevated to an advanced form of relationship building with a little effort, as this Whiteboard Friday by Rand so graciously illustrates.

25. Tier Your Link Building… Forever

The truth is, for professionals, link building never ends. Each content and link building campaign layers on top of previous content and the web as a whole like layers of fine Greek baklava.

For example, this post could be considered linkbait for SEOmoz, but it also links generously to several other content pieces within the Moz family and externally as well; spreading both the link love and the relationship building as far as possible at the same time.

SEOmoz links generously to other sites: the link building experience is not just about search engines, but the people experience, as well. We link to great resources and build links for the best user experience possible. When done right, the search engines reward exactly this type of experience with higher rankings.

For an excellent explanation as to why you should link out to external sites when warranted, read AJ Kohns excellent work, Time to Long Click.

One of my favorite posts on SEOmoz was 10 Ugly SEO Tools that Actually Rock. Not only was the first link on the page directed to our own SEO tools, but we linked and praised our competitors as well.

Call now. 1-888-980-4738